VBA Sverweis mit me...
 
Notifications
Clear all

[Gelöst] VBA Sverweis mit mehreren Treffern  

Seite 1 / 2
  RSS
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

Hallo,

 

wie kann ich einen Sverweis mit mehreren Treffern als VBA schreiben?

Es soll in Tabelle "Selbstaufschreibung" nach dem Suchkriterium aus Zelle B3 gesucht werden und die Namen aus Spalte "E" ausgegeben werden

Zitat
Veröffentlicht : 23/11/2019 9:12 pm
Patrick Schulze
Mitglied Admin

Hi @TWeinsheimer

schön dich hier im Forum zu sehen.

Kannst du mir bitte einmal deine aktuelle Formel zeigen?
Dein Suchkriterium steht in B3 richtig?

Viel Spaß hier

Gruss Patrick

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 9:36 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Habe noch keine Formel.

Richtig, Suchkriterium steht in B3

AntwortZitat
Veröffentlicht : 23/11/2019 9:38 pm
Patrick Schulze
Mitglied Admin

Achso ok, ich muss an der Stelle leider auch zugeben das ich mit SVERWEIS noch nicht gearbeitet habe und mich deswegen gerade da ein bissl einlese.

ich habe folgendes gefunden:

=SVERWEIS(Suchkriterium;Matrix;Spaltenindex;[Bereich_Verweis])

  • Suchkriterium: Hier schreiben Sie die Eingabezelle hin.
  • Matrix: Hier geben Sie den Bereich ein, in welcher Excel nach dem Suchkriterium suchen soll (also den Bereich Ihrer Matrix, einschließlich der letzten benötigten Spalte).
  • Spaltenindex: Hier geben Sie die Spaltennummer ein, in welcher Excel den gesuchten Wert suchen soll.
  • [Bereich_Verweis]: Hier müssen Sie angeben, ob das gesuchte Ergebnis nur in etwa mit dem Suchbegriff übereinstimmen soll (WAHR) oder komplett übereinstimmen soll (FALSCH).

Quelle: https://www.heise.de/tipps-tricks/Excel-SVERWEIS-einfach-erklaert-3971576.html#sverweis_beispiele

Das heisst du kannst schon mal =SVERWEIS("B3") eingeben.

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 9:42 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Der Sverweis ist mir vertraut. Jedoch gibt er immer nur den Wert aus der 1. passenden Zeile aus, nicht aber weitere passende Zeilen.. 🙁

 

 

AntwortZitat
Veröffentlicht : 23/11/2019 9:46 pm
Patrick Schulze
Mitglied Admin

@tweinsheimer

Ich habe jetzt mal anhand der Datei die du mir geschickt hast folgende Formel erstellt, die leider abe rnichts ausgibt.

=SVERWEIS(B3;A3:H5;3;FALSCH)

Ich verstehe noch nicht so ganz woher Excel wissen soll wie der Name bezogen wird.

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 9:52 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Es sollen alle Namen aus Spalte E ausgegeben werden, wenn sie an dem gesuchten Auftrag aus Spalte B arbeiten

AntwortZitat
Veröffentlicht : 23/11/2019 9:58 pm
Patrick Schulze
Mitglied Admin

@tweinsheimer

So ich habe nun, nachdem du mir die Datei per E-Mail geschickt hast dir mal einen kleinen VBA Code gezaubert.
Danke hat Spass gemacht.

Public Sub ma_finder()

'Startzeile der Tabelle in der die eintragungen beginnen (Zeile 3)
'Danach werden die Zellen solange durchlaufen bis eine Leere Zelle kommt.
'Dies wird gemacht um zu wissen, wieviele Zellen mit inhalt vorhanden sind
'Created by Webster-IT.de - Patrick Schulze 23.11.2019
'
'In der Variable wird bestimmt welcher Auftrag gesucht wird
'
'Die For Schleife beginnt bei der ersten Zeile mit Inhalt (Zeile 3)
'Dann wird der vorher gefundene Wert als End Indikator verwendet um zu wissen wie Lange die For Schleife laufen muss
'Danach wird per If abfrage der gesuchte Wert in der Spalte B gesucht
'Wurde der Wert gefunden wird der Name in einer MsgBox ausgegeben.
'--------------------------------------------------------------------------------------------------------------------
Startzeile_Benutzer = 3
          Do While Worksheets("Selbstaufschreibung").Range("B" & Startzeile_Benutzer) <> ""
                Startzeile_Benutzer = Startzeile_Benutzer + 1
          Loop

Suche = 4444

          For i = 3 To Startzeile_Benutzer
                If Range("B" & i) = Suche Then
                        MsgBox Worksheets("Selbstaufschreibung").Range("E" & i), vbInformation, "Mitarbeiter gefunden"
               End If
          Next i
End Sub

Diesen Code kannst du dir jetzt noch mit einem Input Feld erstellen so kannst du da eine Art Suche mit erstellen.
Wenn du dir das umbauen magst und weitere Fragen hast meld dich gerne.

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 10:33 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Funktioniert perfekt!

 

Dankeschön ! 🙂

AntwortZitat
Veröffentlicht : 23/11/2019 10:38 pm
Patrick Schulze gefällt das
Patrick Schulze
Mitglied Admin

@tweinsheimer

Per Chat hattest du mich gefragt ob ich dir, dass noch in deine UserForm einbauen kann.

anbei erhölst du die Datei mit der umgebauten UserForm.

Guck es dir mal an, bei Fragen sag bescheid, aber bitte hier im Thema, Danke.

 

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 11:09 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Vielen Dank für die schnelle und kompetente Hilfe!

AntwortZitat
Veröffentlicht : 23/11/2019 11:17 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Wenn die gesuchte Auftragsnummer aus Zeile 3 beispielsweise auch in in Zeile 5 enthalten ist, so wird auch der Name dazwischen aus Zeile 4 angezeigt. 

Lässt sich das noch abändern?

AntwortZitat
Veröffentlicht : 23/11/2019 11:26 pm
Patrick Schulze
Mitglied Admin

Anbei erhälst du eine geänderte Version deine Excel-Datei.

Ich habe hier auch nochmal etwas anderes eingebaut: Wenn nun die UserForm aufgemacht wird, dann werden alle Listen eintragungen entfernt und danach neu Hinzugefügt.
Für den Fall, wenn sich etwas geändert hat.

Diese r Beitrag wurde geändert 1 Jahr zuvor von Patrick Schulze

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 11:30 pm
TWeinsheimer
(@tweinsheimer)
Mitglieder Moderator

@pschulze

Genial, wie schnell  du es hinbekommen hast 🙂

AntwortZitat
Veröffentlicht : 23/11/2019 11:36 pm
Patrick Schulze
Mitglied Admin

Danke, sehr gerne.

Freut mich wenn ich dir helfen konnte.
Wir haben jetzt dennoch gesamt etwa 2 Stunden gebraucht.

Gründer und Administrator von Seo-Rec.net

Bei Fragen oder Problemen könnt Ihr mich gerne anschreiben im Community Chat oder per E-Mail.

Meine Firmen Website: https://webster-it.de
Viel Spaß bei SEO-Rec!

AntwortZitat
Veröffentlicht : 23/11/2019 11:38 pm
Seite 1 / 2